TLS Notification

TLS Notification

150 150 Aspen Grove Solutions

TLSOverview

On June 30th, 2018, the Payment Card Industry Data Security Standard (PCI DSS) will enforce the disablement of TLS versions 1.0 and 1.1. To ensure compliance, Aspen Grove Solutions will support this change ahead of time on May 15th in a phased approach covering all systems.

Why the change?

This is a positive security enhancement to enable the protection of credit card information over a secure channel.

When will this change happen?

This is a phased approach across all systems, beginning on May 15th and scheduled to finish for June 20th, 2018. For more specific information on a system, please contact security@aspengrovesolutions.com.

How will this affect me?

Users operating unsupported browsers or operating systems may be affected by this change.

Please check using the handy link below to see if your current browser is supported:

https://www.ssllabs.com/ssltest/viewMyClient.html

Most Aspen customers using modern browsers and operating systems will not be affected.  Only very old browsers and operating systems will be unable to make connections using the newer TLS protocol.  Beginning May 17th, 2018, it will be necessary to use an operating system and browser capable of connections using TLS 1.1 or higher.

See the list below for minimum required versions:

Compatible Operating Systems:

Windows 7
Windows 8
Windows 8.1
Windows 10
Windows Server 2008 R2
Windows Server 2012

Compatible Browsers:

Chrome v22 or higher
Firefox v27 or higher
Internet Explorer 8-10 (if TLS 1.1 is enabled)
Internet Explorer 11 and higher (TLS 1.1 is enabled by default)
Safari v7 or higher
Edge

Compatible Mobile Browsers:

Chrome on Android Jelly Bean 4.1-4.3.1 and Android KitKat 4.4-4.4.4 (if TLS 1.1 is enabled)
Chrome on Android Lollipop 5.0-5.0.2 and higher (TLS 1.1 is enabled by default)
Safari v5 and higher
Internet Explorer Mobile on Windows Phone 8 (if TLS 1.1 is enabled)
Internet Explorer Mobile on Windows Phone 8.1 and higher (TLS 1.1 is enabled by default)
Edge all versions
Opera 12.18 and later.

What can I do if I’m not compliant?

Non-compliant customers must update their browser or operating systems to one of the supported systems listed above. Customers will not be able to connect to any global systems accepting credit card payments after June 30th.

Questions

If you require further information or have any questions please don’t hesitate to ask by emailing security@aspengrovesolutions.com or contacting our customer care team on 240 8959 200.

Leave a Reply